通达信龙骨架主图指标公式

2022年9月23日通达信公式评论862951字

指标介绍:

当主图MACD三线交叉向上、股价穿越交叉线,即为股票的强势起涨点。

图中:红线为日线MACD,粉线为周线MACD,黄线为月线MACD。

当红、粉两线逐步融合、和黄线接近并交叉融合时,提示龙尾正在形成。再横盘、再融合、再交叉,如此演变二至三个周期左右,龙身长成,露出龙头。之后,龙头一路飞腾,甚至直冲云霄。

DRAWGBK(C>0,RGB(0,10,10),RGB(88,0,0),0,'0',0);
DRAWGBK(C>0,RGB(40,120,20),RGB(00,00,00),0,'0',1);
DRAWGBK(C>0,RGB(80,100,120),RGB(00,00,00),0,'0',1);
DRAWKLINE(H,O,L,C);
DRAWTEXT_FIX(FINANCE(51)<>0,0.85,0.02,0,'含可转债')COLORYELLOW;
{寻龙诀色带}
强弱分界:=Ema(COst(85),10){,PRECISION2,LINEDOT},COLORRED,DOTLINE;
分界:=EMA(COST(99),10){,PRECISION2,LINEDOT},COLORGREEN,DOTLINE;
{DRAWBAND(强弱分界,RGB(80,80,20), 分界,RGB(60,60,18));
DRAWKLINE(H,O,L,C);}
{龙骨架——macd日周月共振主图}
月DIF:=(EMA(CLOSE,12*4*4)-EMA(CLOSE,26*4*4));
月DEA:=EMA(月DIF,9*4*4);
月MacD:=2*(月DIF-月DEA),COLORSTICK,COLOR111111;
月柱:=月MACD,COLOR99EEEE,LINETHICK3;
周DIF:=(EMA(CLOSE,12*4)-EMA(CLOSE,26*4));
周DEA:=EMA(周DIF,9*4),COLORWHITE,DOTLINE;
周MACD:=2*(周DIF-周DEA),COLORSTICK,COLOR111111;
周柱:=周MACD,COLORFFCC00,LINETHICK2;
日DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26));
日DEA:=EMA(日DIF,9);
日MACD:=2*(日DIF-日DEA),COLORWHITE;
日柱:=日MACD,COLORRED;
{MACD日周月共振线}
{顶部}
VAR10:=日柱;
VAR11:=HHV(HHV(LOW,14),40);
上一:EMA(EMA(VAR11,14)+2*STD(VAR11,14),8),LINETHICK2,COLORRED;
VAR20:=周柱;
VAR21:=HHV(HHV(LOW,14),120);
上二:EMA(EMA(VAR21,14)+2*STD(VAR21,14),8),,LINETHICK2,COLORMAGENTA;
VAR30:=月柱;
VAR31:=HHV(HHV(LOW,14),240);
上三:EMA(EMA(VAR31,14)+2*STD(VAR31,14),8),LINETHICK3,COLORYELLOW;
{底部}
VAR15:=LLV(LLV(HIGH,14),40);
VAR16:=LLV(MA((L+H+C)/3,8),40),COLORFF00FF;
下一:=EMA(EMA(VAR15,14)+2*STD(VAR15,14),8),LINETHICK1,COLORCYAN;
VAR25:=LLV(LLV(HIGH,14),120);
VAR26:=LLV(MA((L+H+C)/3,8),120),COLORFF00FF;
下二:=EMA(EMA(VAR25,14)+2*STD(VAR25,14),8),LINETHICK2,COLORGREEN;
VAR35:=LLV(LLV(HIGH,14),240);
VAR36:=LLV(MA((L+H+C)/3,8),240),COLORFF00FF;
下三:=EMA(EMA(VAR35,14)+2*STD(VAR35,14),8),LINETHICK3,COLORBLUE;
{涨停k线}
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
{无抛压缩量板}
无量停板7:=MA(C,5)>REF(MA(C,5),1) AND C/REF(C,1)>1.099 AND V<MA(V,5)COLOR7210CD;
STICKLINE(无量停板7,C,O,3,0) ,COLOR7210CD;
{板块市值业绩}
Z111:=STRCAT(HYBLOCK,'----');
Z211:=STRCAT(Z111,FGBLOCK);
Z311:=STRCAT(Z211,DYBLOCK);
Z411:=STRCAT(Z311,'----');
DRAWTEXT_FIX(1,0.00,0.06,0,'【主题概念】:')COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.07,0.06,0,STRCAT(Z411,GNBLOCK)),COLORCYAN;
DRAWTEXT_FIX(1,0.07,0.24,0,EXTERNSTR(0,14))COLORYELLOW;
总股本:=STRCAT(STRCAT(' 总股本:',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘:',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(STRCAT(' 全流通:',CON2STR(CAPITAL/TOTALCAPITAL*100,2)),'%');
市值:=STRCAT(STRCAT(' 流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.005,0,上市日期),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.099,0.005,0,总股本),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.175,0.005,0,流通盘),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.260,0.005,0,市值),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.12,0,STRCAT(STRSPACE(DYBLOCK),HYBLOCK)),COLORCYAN;
DRAWTEXT_FIX(FINANCE(51)<>0,0.1,0.12,0,'含可转债')COLORYELLOW;

778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友