通达信VIP分时T+0主图指标公式

2022年8月27日通达信公式评论694609字
{蓝色箱体}
VR1:=1270915;vr2:=1270920;
VR3:=IF(DATE>VR1,IF(CLOSE<80,1,0),0);
VR4:=IF(DATE>VR2,1,VR3);
X_2R:=AMOUNT/vol/100;
X_3R:=SUM(CLOSE*VOL,0)/SUM(VOL,0);
X_4R:=(SETCODE=0 OR SETCODE=1) AND CLOSE<500;
均价W:=IF(X_4R,X_3R,X_3R),COLORYELLOW;
HHJ:IF(SETCODE>=0 AND CONst(BARSSINCE(CLOSE))<900,CONST(IF(BARSSINCE(C>0)<30,HHV(CLOSE,0),SUM(IF(BARSSINCE(C>0)=30,1,0)*HHV(CLOSE,0),0))),DRAWNULL),DOTLINE,COLORBLUE;
LLJ:IF(SETCODE>=0 AND CONST(BARSSINCE(CLOSE))<900,CONST(IF(BARSSINCE(C>0)<30,HHV(CLOSE,0),SUM(IF(BARSSINCE(C>0)=30,1,0)*LLV(CLOSE,0),0))),DRAWNULL),DOTLINE,COLORBLUE;
STICKLINE((BARSSINCE(C>0)=1 OR BARSSINCE(C>0)=30) AND VR4<>1,HHJ,LLJ,1,0),COLORFF0000;
AF1:=1;
TT:=BArslAST(HOUR=9 AND MINUTE=(30+AF1))+1;
均价:=SUM(V*C,0)/SUM(V,0);
价位:=C,COLORWHITE,LINETHICK4;
盘整:=IF(HOUR>9 AND RANGE(HHV(C,60)/LLV(C,60),1,1.02),C,DRAWNULL),COLORRED,LINETHICK2;
V1:=V;
HH:=C>REF(C,1) AND C/均价>(1+0.03);
LL:=C<REF(C,1) AND C/均价<(1-0.03);
HH1:=crOSS(SUM(HH,0),0.5);
LL1:=CROSS(SUM(LL,0),0.5);
SS1:=SUM(HH1,0)*CROSS(COUNT(C<REF(C,1),BARSLAST(HH1)),0.5);
BB1:=SUM(LL1,0)*CROSS(COUNT(C>REF(C,1),BARSLAST(LL1)),0.5);
CS1:CONST(SUM(IF(SS1,REF(C,1),DRAWNULL),0))DOTLINE,COLORGREEN,LINETHICK1;
CB1:CONST(SUM(IF(BB1,REF(C,1),DRAWNULL),0))DOTLINE,COLORmaGENTA,LINETHICK1;
HH2:=CROSS(SUM(HH AND C>CS1*1.03,0),0.5);
LL2:=CROSS(SUM(LL AND C<CB1*0.97,0),0.5);
SS2:=SUM(HH2,0)*CROSS(COUNT(C<REF(C,1),BARSLAST(HH2)),0.5);
BB2:=SUM(LL2,0)*CROSS(COUNT(C>REF(C,1),BARSLAST(LL2)),0.5);
CS2:CONST(SUM(IF(SS2,REF(C,1),DRAWNULL),0))DOTLINE,COLORGREEN,LINETHICK1;
CB2:CONST(SUM(IF(BB2,REF(C,1),DRAWNULL),0))DOTLINE,COLORMAGENTA,LINETHICK1;
DRAWICON(BB1 OR BB2,REF(C,1)*0.999,44);
DRAWICON(SS1 OR SS2,REF(C,1)*1.00,45);
牵牛线:=EMA(CLOSE,34)-EMA(CLOSE,888);
牛道:=EMA(牵牛线,888);DRAWICON(CROSS(牵牛线,牛道),C,25);
量价:=(VOL/CLOSE)/3;
A2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
A3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
A6:=A2+A3;DD1:=1;比:=A2/A3;
AAA1:=STRCAT(STRCAT('买= ',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('卖= ',CON2STR((100*A3)/A6,0)),'%');
AAA3:=STRCAT(STRCAT('差= ',CON2STR((100*(A2-A3))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0,0.04,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0,0.12,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0,0.20,0,AAA3),COLOR00FFFF;
DRAWTEXT_FIX(比>2,0,0.40,0,'涨'),COLORCYAN;
DRAWTEXT_FIX(比>2,0,0.48,0,'停'),COLORMAGENTA;
DRAWTEXT_FIX(比>2,0,0.56,0,'板'),COLORRED;
中期线:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;
{ DRAWTEXT(比<1.1,(DYNAINFO(5)+DYNAINFO(6))/2,'.'),COLORGREEN;
DRAWTEXT(比>1.5,(DYNAINFO(5)+DYNAINFO(6))/2,'.'),COLORCYAN;
DRAWTEXT(比>2,(DYNAINFO(5)+DYNAINFO(6))/2,'.'),COLORMAGENTA;
DRAWTEXT(比>2.5,(DYNAINFO(5)+DYNAINFO(6))/2,'.'),COLORRED;
DRAWTEXT((比>1.1 AND 中期线<5),(DYNAINFO(5)+DYNAINFO(6))/2,'.'),COLORWHITE;
DRAWTEXT((比<1.1 AND 中期线>98.0),(DYNAINFO(5)+DYNAINFO(6))/2,'.'),COLORWHITE;{●○}
{DRAWTEXT((比>1.1 AND 中期线<5),C,'--机会'),COLORYELLOW;}
DRAWTEXT(FILTER(比<1.1 AND 中期线>98.0,24),C,'--风险'),COLORYELLOW;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORGREEN;
支撑:=L1+P1*0.5/8,COLORMAGENTA;
DRAWTEXT(LONGCROSS(支撑,C,2),C,'--买入'),COLORFF00FF;
DRAWTEXT(LONGCROSS(C,阻力,2),C,'--出货'),COLOR70DB93;
LC:=REF(CLOSE,1);
Wrsi:=SMA(MAX(CLOSE-LC,0),9,1)/SMA(Abs(CLOSE-LC),9,1)*100;
DRAWICON(CROSS(20,wrSI),C,1);
DRAWICON(CROSS(WRSI,80),C,2);
DRAWICON(CROSS(20,"RSI.RSI1"(9)),C,1);
DRAWICON(CROSS("RSI.RSI1"(9),80),C,2);
均价1:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK1;
TT1:=BARSCOUNT(C);均:=MA(C,TT1);
上均线:=均+2*STD(C,3);下均线:=均-2*STD(C,3);
时长:=TIME>93000;涨幅:=C/REF(C,1)>1.02;跌幅:=C/REF(C,1)<0.98;
横盘:=((HHV(C,TT1)-LLV(C,TT1))/C)<0.05;YY:=SMA(VOL,30,1);
放量:=(YY-LLV(LLV(YY,1),30))/(HHV(HHV(YY,1),30)-LLV(LLV(YY,1),30))>0.95;
涨跌幅:=涨幅 OR 跌幅;
横涨1:=涨跌幅=0 AND 横盘 AND 放量 AND CROSS(均价1,均);
DRAWTEXT(FILTER(横涨1,10),C,'突'),COLORYELLOW;
DRAWICON(FILTER(横涨1,10),均价1,1);
IF(macd.DEA<0,C,DRAWNULL),COLORMAGENTA ,LINETHICK9;
XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
主力:=expma(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);
底:=1;1.02,NODRAW;高:=1.03;
AA:=主力>大户 AND 主力>1.003 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60);
DRAWICON(主力>大户 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60) AND 主力=HHV(主力,30) AND CROSS(主力,1.003),C,38);
DRAWTEXT(主力>大户 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60) AND 主力=HHV(主力,30) AND CROSS(主力,1.003),C*0.999,'-主力'),COLORYELLOW;
{ DRAWICON(CROSS(主力,1.02),C,24);}
DRAWTEXT(CROSS(主力,1.02),C*0.999,'--拉升'),COLORCYAN;
{ DRAWICON(CROSS(主力,1.04),C,6);}
DRAWTEXT(CROSS(主力,1.04),C*0.999,'--冲涨停'),COLORRED;
{ DRAWICON(CROSS(散户,主力),C,6);}
DRAWTEXT(CROSS(散户,主力),C*0.9995,'--小心'),COLORGREEN;
{DRAWICON(CROSS(散户,大户),C,6);}
DRAWTEXT(CROSS(散户,大户),C*0.9995,'--走弱'),COLORGREEN;

778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友