通达信强股回调主图指标公式

2022年8月27日通达信公式评论472742字
M:=5;
N:=10;
A:=20;
W:=30;
X:=60;
Y:=120;
Z:=250;
ma5 : MA(C,M);
MA10 : MA(C,N);
MA20 : MA(C,A);
MA60 : MA(C,X),COLORGREEN;
VAR0 := ((REF(C,1) < REF(OPEN,1)) OR (C <= REF(C,1))) AND ((C > OPEN) OR ((C = OPEN) AND (OPEN > LOW)));
VAR1 := ((C > REF(C,1)) AND (C < OPEN)) AND (MA(C,10) > REF(MA(C,10),1));
VAR2 := (C < MA(C,5)) AND (VAR0 OR VAR1);
VAR3 := C > (REF(C,1) * 1.095);
VAR4 := ((C > OPEN) AND (vol > (MA(VOL,120) * 3))) OR VAR3;
VAR5 := EVERY(VAR4,3) AND EXIst(VAR3,4);
VAR6 := EXIST(VAR5,6) AND VAR2;
VAR7 := EXIST(VAR3,10) AND (REF(MA(C,20),1) > (REF(MA(C,20),5) * 1.03));
VAR8 := (COUNT(C > (REF(C,1) * 1.095),5)) >= 2;
VAR9 := EXIST(VAR8,5) AND VAR2;
VAR10 := ((EXIST(C > (REF(C,1) * 1.095),5)) AND (EXIST(C > (REF(C,2) * 1.16),5))) AND (EXIST(LOW > REF(HIGH,1),5));
VAR11 := VAR10 AND VAR2;
VAR12 := ((REF(MA(C,5),1) > (REF(MA(C,5),2) * 1.02)) AND (REF(MA(C,5),1) > (REF(MA(C,5),5) * 1.1))) AND (MA(C,30) > MA(C,60));
VAR13 := ((REF(MA(C,10),1) > (REF(MA(C,10),2) * 1.016)) AND (REF(MA(C,10),1) > (REF(MA(C,10),5) * 1.1))) AND (MA(C,30) > MA(C,60));
VAR14 := (VAR12 OR VAR13) AND VAR2;
VAR15 := VOL > MA(VOL,120);
VAR16 := MA(VOL,5) > (MA(VOL,120) * 2);
VAR17 := (EVERY(VAR15,15) OR EVERY(VAR16,10)) AND EXIST(VAR3,15);
VAR18 := (REF(MA(C,5),1) > (REF(MA(C,5),5) * 1.03)) AND ((REF(MA(C,5),1) > (REF(MA(C,5),2) * 1.01)) OR (MA(C,5) > (REF(MA(C,5),1) * 1.01)));
VAR19 := (REF(MA(C,10),1) > (REF(MA(C,10),5) * 1.03)) AND ((REF(MA(C,10),1) > (REF(MA(C,10),2) * 1.01)) OR (MA(C,10) > (REF(MA(C,10),1) * 1.01)));
VAR20 := (((((REF(MA(C,20),1) > (REF(MA(C,20),5) * 1.03)) AND (REF(MA(C,20),1) > (REF(MA(C,20),2) * 1.008))) AND (MA(C,5) > MA(C,10))) AND (REF(MA(C,30),1) > (REF(MA(C,30),5) * 1.03))) AND (REF(MA(C,30),1) > (REF(MA(C,30),2) * 1.008))) AND (MA(C,10) > (REF(MA(C,10),5) * 1.03));
VAR21 := ((((((C < MA(C,5)) AND (REF(MA(C,5),2) > (REF(MA(C,5),4) * 1.02))) AND (REF(MA(C,5),3) > (REF(MA(C,5),5) * 1.02))) AND (REF(MA(C,10),2) > (REF(MA(C,10),4) * 1.02))) AND (REF(MA(C,10),3) > (REF(MA(C,10),5) * 1.02))) AND (MA(C,10) > (REF(MA(C,10),2) * 1.016))) AND (MA(C,20) > (REF(MA(C,20),2) * 1.006));
VAR22 := (REF(VAR18,3) OR REF(VAR19,3)) AND (REF(MA(C,5),3) > REF(MA(C,10),3));
VAR23 := ((REF(C,3) > REF(MA(C,5),3)) OR (REF(C,2) > REF(MA(C,5),2))) AND (REF(C,3) > REF(MA(C,10),3));
VAR24 := (C < MA(C,10)) AND (MA(C,30) > (REF(MA(C,30),5) * 1.02));
VAR25 := (VAR22 AND VAR23) AND VAR24;
VAR26 := (((VAR7 OR EXIST(VAR5,20)) OR EXIST(VAR8,20)) OR EXIST(VAR17,20)) OR EXIST(VAR10,20);
VAR27 := (VAR2 AND (((VAR18 OR VAR19) OR VAR20) OR VAR21)) AND VAR26;
VAR28 := VAR26 AND VAR2;
VAR29 := ((VAR6 OR VAR14) OR VAR11) OR VAR27;
VAR30 := VAR25 AND VAR28;
DRAWICON(VAR29,LOW * 0.98,1);
DRAWICON(VAR30,LOW * 0.97,11);
DRAWICON(VAR9,LOW * 0.95,5);
VAR31 := (((VOL * 240) / FROMOPEN) < (LLV(VOL,10) * 1.1)) AND ((((VOL * 240) / FROMOPEN) / REF(MA(VOL,5),1)) < 0.8);
VAR32 := VAR31 AND ((VAR29 OR VAR30) OR VAR9);
VAR33 := ((VOL * 240) / FROMOPEN) / REF(MA(VOL,5),1);
VAR34 := (AMOUNT / VOL) / 100;
VAR35 := REF(C,1);
VAR36 := (IF(((REF(C,1) * 1.1) - C) < 0.005,1,0)) AND (C > OPEN);
STICKLINE(VAR36,OPEN,C,4,0),COLORRED;
STICKLINE(VAR36,OPEN,C,3,0),COLORYELLOW;
STICKLINE(VAR36,HIGH,LOW,0,0),COLORYELLOW;

778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友