通达信游资活跃度指标公式

2022年7月8日通达信公式评论342766字
N:=5;
X_1:=Ema(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
X_3:=X_1>0;
X_4:=X_2>0;
X_5:=crOSS(dmi.pdi,30);
X_6:=CROSS(DMI.PDI,40);
X_7:=CROSS(DMI.PDI,44);
X_8:=CROSS(DMI.PDI,37);
X_9:=CROSS(X_1,X_2);
X_10:=vol/REF(VOL,1)>1.05;
X_11:=VOL/REF(VOL,1)>1.5;
X_12:=VOL/REF(VOL,1)>2;
X_13:=VOL/REF(VOL,1)>5;
X_14:=VOL/REF(VOL,1)>2.5;
X_15:=VOL/REF(VOL,2)>2 AND VOL/REF(VOL,1)>1.3;
X_16:=CLOSE>REF(CLOSE,1);
X_17:=CLOSE/REF(CLOSE,1)>1.02;
X_18:=CLOSE/REF(CLOSE,1)>1.09;
X_19:=CLOSE=HHV(CLOSE,15);
X_20:=X_6 AND X_11 AND X_17;
X_21:=X_3 AND X_4 AND X_5 AND X_11 AND X_17;
X_22:=X_4 AND X_6 AND X_12 AND X_17 AND X_19;
X_23:=X_3 AND X_6 AND X_13 AND X_17 AND X_19;
X_24:=X_3 AND X_7 AND X_12 AND X_17 AND X_19;
X_25:=X_3 AND X_4 AND X_8 AND X_14 AND X_17 AND X_19;
X_26:=X_3 AND X_4 AND X_7 AND X_15 AND X_17 AND X_19;
X_27:=X_3 AND X_4 AND X_9 AND X_10 AND X_18 AND X_19;
stICKLINE(X_27,0,100,0.1,0),COLORRED;
DRAWTEXT(X_27,80,1),COLORMAGENTA;
STICKLINE(X_26,0,100,0.1,0),COLORRED;
DRAWTEXT(X_26,80,1),COLORMAGENTA;
STICKLINE(X_25,0,100,0.1,0),COLORRED;
DRAWTEXT(X_25,80,1),COLORMAGENTA;
STICKLINE(X_24,0,100,0.1,0),COLORRED;
DRAWTEXT(X_24,80,1),COLORMAGENTA;
STICKLINE(X_23,0,100,0.1,0),COLORRED;
DRAWTEXT(X_23,80,1),COLORMAGENTA;
STICKLINE(X_22,0,100,0.1,0),COLORRED;
DRAWTEXT(X_22,80,1),COLORMAGENTA;
STICKLINE(X_20,0,30,0.1,0),COLORRED;
DRAWTEXT(X_20,20,2),COLORMAGENTA;
STICKLINE(X_21,0,50,0.1,0),COLORRED;
DRAWTEXT(X_21,30,2),COLORMAGENTA;
X_28:=SUM(MAX(MAX(HIGH-LOW,Abs(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
X_29:=HIGH-REF(HIGH,1);
X_30:=REF(LOW,1)-LOW;
X_31:=SUM(IF(X_29>0 AND X_29>X_30,X_29,0),N);
X_32:=SUM(IF(X_30>0 AND X_30>X_29,X_30,0),N);
游资活跃度:X_31*100/X_28,COLORRED,LINETHICK2;
STICKLINE(CLOSE>0,90,90,28,(-1)),COLORMAGENTA;
STICKLINE(CLOSE>0,80,80,28,(-1)),COLORWHITE;
STICKLINE(CLOSE>0,40,40,28,(-1)),COLORMAGENTA;
STICKLINE(CLOSE>0,20,20,28,(-1)),COLORMAGENTA;
X_33:=EMA(WINNER(CLOSE)*70,5);
X_34:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
STICKLINE(X_22,100,0,3,0),COLOR990099;
STICKLINE(X_22,100,0,2,0),COLORBB00BB;
STICKLINE(X_22,100,0,1,0),COLORDD00DD;
STICKLINE(X_22,100,0,0.3,0),COLORMAGENTA;
STICKLINE(X_23,100,0,3,0),COLOR990099;
STICKLINE(X_23,100,0,2,0),COLORBB00BB;
STICKLINE(X_23,100,0,1,0),COLORDD00DD;
STICKLINE(X_23,100,0,0.3,0),COLORMAGENTA;
STICKLINE(X_24,100,0,3,0),COLOR990099;
STICKLINE(X_24,100,0,2,0),COLORBB00BB;
STICKLINE(X_24,100,0,1,0),COLORDD00DD;
STICKLINE(X_24,100,0,0.3,0),COLORMAGENTA;
STICKLINE(X_25,100,0,3,0),COLOR990099;
STICKLINE(X_25,100,0,2,0),COLORBB00BB;
STICKLINE(X_25,100,0,1,0),COLORDD00DD;
STICKLINE(X_25,100,0,0.3,0),COLORMAGENTA;
STICKLINE(X_26,100,0,3,0),COLOR990099;
STICKLINE(X_26,100,0,2,0),COLORBB00BB;
STICKLINE(X_26,100,0,1,0),COLORDD00DD;
STICKLINE(X_26,100,0,0.3,0),COLORMAGENTA;
STICKLINE(X_27,100,0,3,0),COLOR990099;
STICKLINE(X_27,100,0,2,0),COLORBB00BB;
STICKLINE(X_27,100,0,1,0),COLORDD00DD;
STICKLINE(X_27,100,0,0.3,0),COLORMAGENTA;

778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友