通达信波段趋势强弱主图指标公式

2022年5月11日通达信公式评论262211字
X_1:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X_2:=Ema(X_1,13);
X_3:=EMA(X_2,3);
X_4:=EMA(X_3,3);
X_5:=EMA(X_4,3);
X_6:=EMA(X_5,3);
X_7:=EMA(X_6,3);
DRAWBAND(X_2,RGB(150,50,20),X_7,RGB(36,150,40));
NOTEXTMB101:IF(X_2>X_3,X_2,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB102:IF(X_2<X_3,X_2,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB201:IF(X_3>X_4,X_3,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB202:IF(X_3<X_4,X_3,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB301:IF(X_4>X_5,X_4,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB302:IF(X_4<X_5,X_4,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB401:IF(X_5>X_6,X_5,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB402:IF(X_5<X_6,X_5,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB501:IF(X_6>X_7,X_6,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB502:IF(X_6<X_7,X_6,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB601:IF(X_7>REF(X_7,1),X_7,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB602:IF(X_7<REF(X_7,1),X_7,DRAWNULL),DOTLINE,COLORGREEN;
X_8:=(20*X_1+19*REF(X_1,1)+18*REF(X_1,2)+17*REF(X_1,3)+16*REF(X_1,4)+15*REF(X_1,5)+14*REF(X_1,6)+13*REF(X_1,7)+12*REF(X_1,8)+11*REF(X_1,9)+10*REF(X_1,10)+9*REF(X_1,11)+8*REF(X_1,12)+7*REF(X_1,13)+6*REF(X_1,14)+5*REF(X_1,15)+4*REF(X_1,16)+3*REF(X_1,17)+2*REF(X_1,18)+REF(X_1,20))/210;
X_9:=MA(X_8,20);
X_10:=MA(X_9,2);
DRAWBAND(X_9,RGB(250,0,0),X_10,RGB(250,250,0));
NOTEXTDTTJ:CONst(CLOSE),DOTLINE,COLORGRAY;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
STICKLINE(CLOSE>OPEN,HIGH,LOW,0,0),COLOR7D7DFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0),COLOR7D7DFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.1,0),COLOR1313FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4,0),COLOR2424FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),COLOR2D2DFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.6,0),COLOR4444FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.2,0),COLOR5757FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.6,0),COLOR6666FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.1,0),COLOR7D7DFF;
STICKLINE(CLOSE<OPEN,HIGH,LOW,0,0),COLORAA9900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0,0),COLORAA5500;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3.1,0),COLORAA6600;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2.4,0),COLORAA7700;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2,0),COLORAA8800;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,1.6,0),COLORAA9900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,1.2,0),COLORAAAA00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.6,0),COLORAacC00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.1,0),COLORAADD00;

778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友