同花顺起爆CCI指标公式

2021年12月31日
评论
54 2798字
RR1:=ma(CLOSE,27);
RR2:=(CLOSE-RR1)/RR1*100;
RRA:=MA(RR2,2);
RRB:=BArslAst(crOSS(-10,RRA)=1);
RRD:=RRA<-10 AND RRB>3;
STICKLINE(IF(RRD,-120,0),-120,0,8,0),COLOR33FFFF;
起爆点:IF(RRD,-120,0),COLOR00FF66,colorliblue,LINETHICK2;
TYP := (HIGH + LOW + CLOSE)/3;
cci14:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),colorred,LINETHICK2;
强势线:100,LINETHICK2;
低位线: -100,colorred,LINETHICK2;
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=ema(VAR300,5);
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR2:=LLV(LOW,20);
VAR3:=HHV(HIGH,20);
操盘:=3*VAR300-2*VAR400;
PS1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(PS1,30,-100,3,0),COLORFF00FF;
STICKLINE(PS1,30,-100,2,0),COLORFF66FF;
STICKLINE(PS1,30,-100,1,0),COLORFF66CC;
STICKLINE(PS1,30,-100,1,0),COLORFF99FF;
STICKLINE(PS1,30,-100,1,0),COLORFFCCFF;
STICKLINE(PS1,30,-100,1,0),COLOR00FFFF;
STICKLINE(PS1,30,-100,0.3,0),COLOR66FF33;
DRAWTEXT(PS1,42,'起爆点'),coloryellow;
//六大金叉
LDdifF:=EMA(CLOSE,12)-EMA(CLOSE,26);
LddeA:=EMA(LddiFF,9);
//{STICKLINE(DIFF>DEA,1,1.8,3,0),colorred;
//STICKLINE(DIFF<DEA,1,1.8,3,0),colorgreen;}
MCDA金叉:LDDIFF>LDDEA,NODRAW;
LDRSV:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
LDK:=SMA(LDRSV,3,1);
LDD:=SMA(LDK,3,1);
//{STICKLINE(K>D,2,2.8,3,0),colorred;
//STICKLINE(K<D,2,2.8,3,0),colorgreen;}
kdj金叉:LDK>LDD,NODRAW;
LDLC:=REF(CLOSE,1);
LDrsi1:=(SMA(MAX(CLOSE-LDLC,0),9,1))/(SMA(Abs(CLOSE-LDLC),9,1))*100;
LDRSI2:=(SMA(MAX(CLOSE-LDLC,0),26,1))/(SMA(ABS(CLOSE-LDLC),26,1))*100;
//{STICKLINE(RSI1>RSI2,3,3.8,3,0),colorred;
//STICKLINE(RSI1<RSI2,3,3.8,3,0),colorgreen;}
RSI金叉:LDRSI1>LDRSI2,NODRAW;
LDLwr1:=SMA(LDRSV,3,1);
LDLWR2:=SMA(LDLWR1,3,1);
//{STICKLINE(LWR1>LWR2,4,4.8,3,0),colorred;
//STICKLINE(LWR1<LWR2,4,4.8,3,0),colorgreen;}
LWR金叉:LDLWR1>LDLWR2,NODRAW;
LDbbi:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;
//{STICKLINE(CLOSE>BBI,5,5.8,3,0),colorred;
//STICKLINE(CLOSE<BBI,5,5.8,3,0),colorgreen;}
BBI金叉:CLOSE>LDBBI,NODRAW;
LDmtm:=CLOSE-REF(CLOSE,1);
LDmms:=100*EMA(EMA(LDMTM,9),9)/EMA(EMA(ABS(LDMTM),9),3);
LDMMM:=100*EMA(EMA(LDMTM,26),12)/EMA(EMA(ABS(LDMTM),26),12);
//{STICKLINE(MMS>MMM,6,6.8,3,0),colorred;
//STICKLINE(MMS<MMM,6,6.8,3,0),colorgreen;}
MMS金叉:LDMMS>LDMMM,NODRAW;
STICKLINE(MCDA金叉 AND kdJ金叉 AND RSI金叉 AND LWR金叉 AND BBI金叉 AND MMS金叉,-110,-120,3,0),coloryellow;
HJ_1:=HHV(HIGH,9)-LLV(LOW,9);
HJ_2:=HHV(HIGH,9)-CLOSE;
HJ_3:=CLOSE-LLV(LOW,9);
HJ_4:=HJ_2/HJ_1*100-70;
HJ_5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
HJ_6:=(2*CLOSE+HIGH+LOW)/4;
HJ_7:=SMA(HJ_3/HJ_1*100,3,1);
HJ_8:=LLV(LOW,34);
HJ_9:=SMA(HJ_7,3,1)-SMA(HJ_4,9,1);
HJ_10:=IF(HJ_9>100,HJ_9-100,0);
HJ_11:=HHV(HIGH,34);
HJ_12:=EMA((HJ_6-HJ_8)/(HJ_11-HJ_8)*100,8);
HJ_13:=EMA(HJ_12,5);
第二指标交叉线:=HJ_12-HJ_13;
买入条件:=-第二指标交叉线;
卖出:=REF(第二指标交叉线,1)>0 AND 第二指标交叉线<=0 OR (第二指标交叉线<1 AND 第二指标交叉线>=0 AND CLOSE<OPEN),colorred;
买入:=卖出=0 AND REF(第二指标交叉线,1)<0 AND 第二指标交叉线>0;
DRAWTEXT(买入,-110,'买入'),coloryellow;
778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友