同花顺主升猎杀指标公式

2021年12月29日
评论
26 3787字
涨幅:=9;高度:=20;跨度:=10;
//{副图(均线切角)};
ma5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
V0:=MA(C,3)>REF(MA(C,3),1) AND MA(C,5)>REF(MA(C,5),1) AND C>MA(C,3)
AND MA(C,3)>MA(C,5) ; //{均线C,MA3,MA5多头排列并向上;}
角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;
选股MA20:IF(角度MA5>45 AND 角度MA10>55 AND 角度MA20>30 ,
1,0),COLOR00FF00;
//{副图(游资资金1)}
N1:=5;
N4:=34;
CQ:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N4)/HHV(C,N4));
饱和度:=IF(SAT>1,1,SAT)*100;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
支撑:=LLV(持股,3);
中期线:=MA(持股,12);
VAR1:=1;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
短期线:=ema((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1*30;
kdDD:=饱和度>=90 AND CQ>80 AND 中期线<90;
KFFF:=BArslAst(crOSS(短期线,中期线))<40 ;
KGGG:=C/REF(C,1)>1+0.01*涨幅;
进场:KDDD AND KFFF AND (C>O OR C/REF(C,1)>1.05) AND KGGG,LINETHICK2,coloryellow;
DRAWTEXT_FIX(1,0.01,0.01,0,'游资资金与超级资金同时出现,意味着多方都有拉升的意愿.'),colorred;
//{幅图(超级资金)}
短线:=EMA(CLOSE,17);
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线:=EMA(KKC,50);
中期:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
KDD:=REF(中期,1)<1 AND 中期>1;
AAA:=(3*C+L+O+H)/6;
C2:=EMA(AAA,6);
C3:=EMA(AAA,5);
SHORT:=12;
LONG:=26;
MID:=9;
dif:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
macd:=(DIF-DEA)*2;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
KAAA1:=EXIST(KDD,3);
KBBB1:=C/REF(C,1)>1+0.01*涨幅;
KAAA2:=支撑>中期线 AND 持股=支撑;
KBBB2:=CROSS(C2,C3);
KCCC2:=EXIST(C/REF(C,1)>1+0.01*涨幅,跨度);
KDDD2:=BARSLAST(中期线>短期线)<跨度;
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*涨幅;
KCCC3:=中线/长线<1+0.01*高度;
超资: IF(KBBB1+KCCC2+KBBB3=3,1,0);
//{幅图(主散系数1)}
ZLCM:=EMA(WINNER(CLOSE)*70,3);//{主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);//{散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;//{散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;//{主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);//{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);//{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);//{//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);//{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);//{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
//{散户套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,0,0),COLOREEEEEE;
//{散户筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,1,0),COLORAAAAAA;
//{主力控盘筹码}
STICKLINE(C>0,ZZLKP,0,0,0),colorblue;
//{铸顶风险区}
STICKLINE(ZZLKP>75,ZZLKP,0,2,0),COLORFFFFFF;
{顶部:(ZZLKP>75),COLORFFFFFF;}
//{主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,4,0),colorred;
//{筑底散兵坑}
STICKLINE(ZSHTL>=90,ZZLKP,0,5,0),COLOR66FFCC;
{底部:(ZSHTL>=90),COLOR66FFCC;}
//{筹码总量上升}
IF(ZCMZL,ZCMZL>REF(ZCMZL,1),DRAWNULL),COLOR0066FF,LINETHICK1;
//{增量资金}
//{------【数值显示】}
散户套牢系数:INTPART(ZSHTL),coloryellow;
主力控盘系数:INTPART(ZZLKP),colorcyan;
买:IF(CROSS(主力控盘系数,散户套牢系数),120,0);
//{幅图 (山顶乖离)}
高:=EMA(C,50)>EMA(C,240);
底点:=BARSLAST(CROSS(EMA(C,240),EMA(C,50)));
时间:=IF(高>0,底点,50);
山顶:C/LLV(C,时间)*100-100;
峰值顶:HHV(山顶,283);
山底:C/HHV(C,250)*100-100;
//{主升副图}
调A:选股MA20;
调B:进场;
调C:超资;
调D:=买;
调E:=峰值顶;
主:=(调A>0 OR 调B>0 OR 调C>0) AND COUNT(调A>0,2)>=1 AND COUNT(调B>0,3)>=1
AND COUNT(调C>0,5)>=1 AND COUNT(调D>0,4)=1;
确定:=IF(主>0 AND COUNT(主>0,10)=1 AND 调E<100 AND 调E>=1,5,0) ;
//{黄金地量红}
NJ:=27;
N2:=9;
VAR1J:=IF(DATE>=1030131,1,1);
VAR2J:=(CLOSE-LLV(LOW,NJ))/(HHV(HIGH,NJ)-LLV(LOW,NJ))*100;
VAR3J:=SMA(VAR2J,3,1)*VAR1J;
VAR4J:=SMA(VAR3J,N2,1)*VAR1J;
VAR5J:=3*VAR3J-2*VAR4J*VAR1J;
黄金地量红:=vol AND VAR5J>VAR4J;
//{趋势红};
VAR3T:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3T,3)-10;
趋势红:=趋势>=REF(趋势,1);
XG:=确定 AND 黄金地量红 AND 趋势红;
778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友