同花顺四线KDJ指标公式

2021年12月28日
评论
39 3900字
20,POINTDOT,colorred;
50,POINTDOT,colorred;
90,POINTDOT,colorred;
高位:=80,COLOR00AA00;
B:=zig(3,51/5)*100,colorwhite;
G:=ma(B,2),coloryellow;
D:=crOSS(B,G)*1000,colorred;
W:=CROSS(G,B)*1000,colorblue;
A30:=MA(C,30);
ANGLEA30:=ATAN((A30/REF(A30,1)-1)*100)*57.3;
ANGLE30:=ANGLEA30>40 OR ANGLEA30<-48;
A10:=MA(C,10);
ANGLEA10:=ATAN((A10/REF(A10,1)-1)*100)*57.3;
ANGLE10:=ANGLEA10>20 OR ANGLEA10<-25 AND CLOSE>MA(CLOSE,20) ;
A3010:=ANGLE30 OR ANGLE10;
AAZT:=COUNT(CLOSE>REF(CLOSE,1)*1.097 ,20)>0;
stICKLINE( W=1000 ,高位*0.01,高位*1.1,9,0),colorcyan;
STICKLINE( D=1000 ,高位*0.01,高位*1.1,9,0),COLOR0099FF;
STICKLINE( W=1000 AND AAZT,高位*0.2,高位*1.1,9,0),colorgreen;
STICKLINE( D=1000 AND AAZT,高位*0.2,高位*1.1,9,0),colorred;
DRAWTEXT(W=1000,(高位*1.2),'空不介入'),coloryellow;
DRAWTEXT(D=1000,(高位*1.2),'多'),colorred;
DRAWTEXT(TROUGHBARS(1,6,1)=0 AND HIGH>LOW+0,50,' -短买'),colorliblue;
DRAWTEXT(PEAKBARS(2,9,1)=1,80,'短卖'),colormagenta;
DRAWTEXT(TROUGHBARS(3,18,1)=0 AND HIGH>LOW+0.1,20,' F中买'),colorcyan;
DRAWTEXT(PEAKBARS(2,15,1)=0,90,'中卖'),colorred;
STICKLINE(ZIG(3,35)>REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)<REF(ZIG(3,35),2),0,90,3,0),colorred;
STICKLINE(ZIG(3,35)<REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)>REF(ZIG(3,35),2),0,90,3,0),colorgreen,;
VAR1V:=4*SMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,5,1)-3*SMA(SMA(
(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,5,1),3.2,1),coloryellow,LINETHICK1;
VAR2V:=8,colorgreen,LINETHICK1;
STICKLINE(CROSS(VAR1V,VAR2V),0,20,5,0),colorwhite;
DRAWTEXT(CROSS(VAR1V,VAR2V),10,' 准备买入'),colorwhite;
买入:=FILTER(COUNT(CROSS((C-MA(C,5))/MA(C,5)*100,0),3)>=1 AND (C-MA(C,30))/MA(C,30)*100>REF((C-MA(C,30))/MA(C,30)*100,1) AND
MA(C,5)>REF(MA(C,5),1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA(C,30),10);
STICKLINE(买入,20,40,5,0),colorred;
DRAWTEXT(买入=1,30,'牛B'),colorred;
A1:=MA(CLOSE,5);
A2:=MA(CLOSE,20);
B1:=REF(A1,1);
B2:=REF(A2,1);
D1:=REF(A1,2);
D2:=REF(A2,2);
E1:=REF(C,1);
XG:=C>E1 AND C>O AND D1<D2 AND B1>B2;
STICKLINE(XG,60,40,5,0),colormagenta;
DRAWTEXT(XG=1,50,'520'),colormagenta;
AA:=(CROSS(CLOSE,((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004) AND ((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004>REF(((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004,1) AND CROSS(CLOSE,((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004) AND ((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004>REF(((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004,1));
STICKLINE(AA,60,80,5,0),coloryellow;
DRAWTEXT(AA=1,70,'牛'),coloryellow;
VAR3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR5:=VAR3<REF(VAR4,1) AND vol>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
STICKLINE(VAR5 AND COUNT(VAR5,30)=1,80,100,5,0),colorcyan;
DRAWTEXT(VAR5 AND COUNT(VAR5,30)=1,90,'红牛'),colorcyan;
RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K0:=SMA(RSV,3,1);
K:=K0;D0:=SMA(K0,2,1);
J1:(3*K0-2*D0),colorred;
J2:MA(J1,2),coloryellow;
MAV:=(2*C+H+L)/4;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
SK: ema((MAV-VAR1)/(VAR2-VAR1)*100,8),colormagenta;
SD: EMA(0.667*REF(SK,1)+0.333*SK,1),colorcyan;
SJ:=3*SK-2*SD;
买线:=ZIG(3,10);
卖线:=MA(买线,3);
VARF1:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR101:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR111:=VARF1<REF(VAR101,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
游资:=(VAR111 AND COUNT(VAR111,30)=1 AND 买线>=卖线);
DRAWTEXT(游资,(SD*0.98),'--游资进'),colorliblue;
STICKLINE(游资,(SD*0.96),SD,9,0),colorliblue;
机构:=((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3))=1) AND (CROSS(ZIG(3,8),REF(ZIG(3,8),1))) AND (CROSS(ZIG(3,13),REF(ZIG(3,13),1)));
DRAWTEXT(机构,(SD*0.67),'--机构进'),coloryellow;
STICKLINE(机构,(SD*0.92),(SD*0.98),9,0),coloryellow;
778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友