通达信测上升阻力指标公式

2021年11月24日
评论
15 2623字
{测上升阻力源码}
DRAWGBK(C>0, RGB(0,0,20),RGB(00,0,0),0,0,1);
DRAWKLINE(H,O,L,C);
{HD LD zig}
HD:=FILTER(BacKSET(FILTER(REF(H,5)=HHV(H,13),5),5+1),6);{高点}
LD:=FILTER(BACKSET(FILTER(REF(L,5)=LLV(L,21),6),6),5);{低点}
DRAWLINE(LD,L,HD,H,0),COLORRED,LINETHICK2;
DRAWLINE(HD,H,LD,L,0),COLORGREEN;
{----------------------------------------------}
{A B C}
J1:=BACKSET(CURRBARSCOUNT=2 ,MIN(BArslAst(HD),BARSLAST(LD))+1);
J2:=J1>REF(J1,1);
DRAWLINE(J2,IF(HD,H,L),CURRBARSCOUNT=2 ,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),DOTLINE,COLORWHITE;
C点:=BARSLAST(LD);
DRAWTEXT(LD AND BARSLAST(HD)<BARSLAST(REF(LD,1)) ,L-0.1,'A'),COLORRED;
DRAWTEXT(HD,H+0.1,'B'),COLORGREEN;
{25T高 100T低}
波1:=12;
PLZ:=CONST(BARSLAST(CONST(FINDHIGH(H,0,25,1))=H))+1;
高25:CONST(IF(PLZ=1,H,REF(H,PLZ-1))),COLORGREEN,DOTLINE;
PLL:=CONST(BARSLAST(CONST(FINDLOW(L,0,100,1))=L))+1;
低100:CONST(IF(PLL=1,L,REF(L,PLL-1))),COLORGREEN,DOTLINE;
波动速率:=100*((高25-低100)/(IF(PLL>PLZ,低100,高25)))/(PLL-PLZ);
BPURC:=CONST(FINDHIGH(H,0,(IF(波1>0,波1,IF(PLZ<PLL,5,10)))*5,1));
BPLZ:=CONST(BARSLAST(BPURC=H))+1;
BQQT:=CONST(FINDLOW(L,0,(IF(波1>0,波1,IF(PLZ<PLL,5,10)))*5,1));
BPLL:=CONST(BARSLAST(BQQT=L))+1;
BLC顶X:=CONST(IF(BPLZ=1,H,REF(H,BPLZ-1)));
BLC低X:=CONST(IF(BPLL=1,L,REF(L,BPLL-1)));
BASE:=IF(波动速率<0,BLC顶X,BLC低X);
BLCZ:=(高25-低100)*(IF(PLL>PLZ,1,-1));
B12:=BASE+(BLCZ*1.382);
B14:=BASE+(BLCZ*1.618);
B200:=BASE+(BLCZ*2);
XZDD:=IF(PLL>PLZ,BPLL,BPLZ);
STICKLINE(CURRBARSCOUNT=XZDD ,BASE,B200,0,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=XZDD,B12,'---------------------------------------------------------------C1')COLORC0FF7F;
DRAWTEXT(CURRBARSCOUNT=XZDD,B14,'---------------------------------------------------------------C2')COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=XZDD,B200,'--------------------------------------------------------------C3')COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,B12,CON2STR(B12,2)),COLORC0FF7F;
DRAWTEXT(CURRBARSCOUNT=10,B14,CON2STR(B14,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=10,B200,CON2STR(B200,2)),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,B200,CON2STR(B200,2)),COLORGREEN;
{合第二个};
B121:=BASE+(BLCZ*0.775)COLORRED;
B141:=BASE+(BLCZ*0.868)COLORRED;
B2001:=BASE+(BLCZ*1)COLORRED;
XZDD1:=IF(PLL>PLZ,BPLL,BPLZ);
STICKLINE(CURRBARSCOUNT=XZDD1 ,BASE,B2001,0,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=XZDD1,B121,'---------------------------C1')COLORC0FF7F;
DRAWTEXT(CURRBARSCOUNT=XZDD1,B141,'---------------------------C2')COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=XZDD1,B2001,'--------------------------C3')COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,B121,CON2STR(B121,2)),COLORC0FF7F;
DRAWTEXT(CURRBARSCOUNT=10,B141,CON2STR(B141,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=10,B2001,CON2STR(B2001,2)),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,B2001,CON2STR(B2001,2)),COLORGREEN;
778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友