【天道兄弟】抓牛进阶实战课:凯利公式的筹码学

2021年11月15日来源:天道兄弟
评论
24 4292字

凯利公式,本质上揭示了如何控制下注的筹码比例,让利润的边际效益最大化的问题。虽然凯利公式更多是一种理想化模型,并且与股票交易有一些区别,但仍可以为我们的一些 交易手法和模式所借鉴。

一、凯利公式的由来

在1955年美国一档火爆的电视节目《64000美元问题》,也就是现在答题类节目的鼻祖,只要答对了问题你的奖金池里的奖金就会持续积累。因为美国人喜欢开盘口“看嘉宾能答到第几题”,所以全美上下迎来了博彩的疯狂。

而美国东海岸是以直播的形式来放送这档节目的,美国西海岸因为信号的延迟会有一定的延时。东海岸的赌徒们可以实时看到答题的结果,并将结果通过电话告知在西海岸的朋友,由于西海岸的朋友有延迟,得知结果后再在西海岸的盘口下注就赢了不少钱。

美国电话电报公司AT&T,一位叫约翰凯利的员工开始研究这里面的数学问题—通话 噪音是如何去影响下注的胜率的。

那么,他就通过了赌马的模型去具体探讨:投资1元,如果成功了,设成功率为P;如果失败了,那么失败概率为1-P

当成功投资1元,赢利b元时,赔率为1:b

当亏损1元,也就是输光了

那么凯利的问题来了,有没有一种办法能够保证我投资不会亏光并且总能够赢利呢?

最终凯利得出了一个最优解,也就是所谓的凯利公式:

如果这个投资是多次重复的,那么最优的投资比例为f

【天道兄弟】抓牛进阶实战课:凯利公式的筹码学

那么分子实际表示的就是赢面的大小,用赢面除以赢利的比例,即为每次投资的最优比例。举个例子,期货市场杠杆比例基本在5-8之间,当我们赢利概率为P=30% , b=3这时的f

【天道兄弟】抓牛进阶实战课:凯利公式的筹码学

也就是说,每次投资操作都投入总资产的6.7%,就能保证不会亏光,并且持续盈利。同样的,当赢利概率P=70%,b=5此时的f

【天道兄弟】抓牛进阶实战课:凯利公式的筹码学

每次投资操作都投入总资产的64%,就能保证不会亏光,并且持续盈利。不管你这一次 投资是失败还是成功,只要能一次又一次的投资,长期看最终都会盈利。

那么,当你的投资的赢利概率是100%时,又会出现什么情况呢,这时f=1也就是全仓梭哈。这就告诉我们,没有百分之百的赢利率时,就不要全仓操作。当公式的分子即赢面小于0时,f<0,即表示赢面小于0时不投资。

二、股票的凯利公式理论

道哥粉都有感受,股票投资最难的地方,往往就是当成功概率是P的时候,全世界都联 起来告诉你你的机会是1—P,大家肯定会调侃如果仅凭一条公式就能成为巴菲特,那么大家早就成为巴菲特了。

那么问题的核心在哪里呢?

第一、首先你的投资的胜率和盈亏比都是可量化的,并且通过自身的投资系统的精研和过滤,投资系统本身能够输出持续且稳定的胜率和盈亏比,那么只要坚持自己的交易系统(赚钱模式),不断重复去操作,最终时间会告诉你答案,给你一个凯利公式的完美解。

回过头来再看看,我们平时的交易无形当中都破坏了这样一个最优的条件:

A、没有自身的稳定交易系统,自身的盈利模式没有固定,造成胜率和盈亏比的不可持续。

B、有了自己的交易系统,连续亏几笔后,就放弃了交易系统,又转而去做其他的模式,这样无形中就放大了系统的不确定性。用分子运动原理解释就是散乱无规则的布朗运动。

第二、凯利公式解决的问题是,当你在已知成功率和盈亏比的前提下,投入多少比例本金,重在筹码仓位管理;而股票交易是个极为庞大复杂的模型,除了仓位管理,还要去具体研究每笔交易的胜率和风报比,它并不是一个简单的赢面为零就不做投资买入的问题,因为每笔股票交易本质上都是一项风险投资,是一种试错,用试错成本去博弈一个高风偏大利润,如果不去下注,永远不知道这笔交易最终能否盈利,这也就和凯利公式的赢面为零形成了悖论。

那么问题的关键又引申到了如何找到胜率和盈亏比可以量化并且高值博的投资交易中,对于A股来说,因为交易制度和规则的原因,就营运而生了打板这一种特殊的能够固定量化的操作模式。

道哥通过数年的量化,编制了自己长年打板使用的量化公式,既然道哥粉丝们买了道哥的课程,那么道哥自然要把最干的干货奉送给大家:我的打板胜率和溢价率(盈亏比)量化系统,不打板的朋友,也可以用来研判个股的股性,可以说是价值连城,也是彩蛋之一。

道粉看这里的股性指标:

【天道兄弟】抓牛进阶实战课:凯利公式的筹码学

概念解释:

大肉:计算过去500个交易日(2年内),非一字涨停板第二日溢价超过5%的次数

溢价率:即变相的盈亏比,计算过去500个交易日(2年内),涨停板第二日溢价超过5%的比率,例如过去2年有30次非一字涨停板,其中第二日给予溢价5%的次数是20次,那么溢价率即为67%

总胜率:计算过去500个交易日(2年内),非一字涨停板封死的比率,例如过去2年一共换手上板50次,但最终封死涨停收盘的次数有35次,那么就有15次是收盘炸板的,总胜 率为35/50=70%

首:即首板的总胜率,计算过去2年所有首板的封死概率

面:即涨停冲板日炸板2个点以内的次数(连板的炸板+首板的炸板)

大面:即涨停冲板日炸板5个点以内的次数

首炸:即统计2年内所有首板上板的炸板次数

连炸:即统计2年内所有连板上板的炸板次数

核A:即统计2年内收盘涨停后的第二日开盘竞价低开5个点以上的次数,也称为核按钮A

核B:即统计2年内涨停板冲板炸板后,第二日开盘竟价低开5个点以上的次数,也成为核按钮B

三连:统计过去2年内,三连板的次数,三连板次数越多,也是股性活跃的一方面表征

涨停:统计过去两年内封死涨停的涨停次数,也是最为纯粹判断股性活跃与否的标志

脸:判断一年内炸板2个点以上的次数,对于超过3次的打板都要再进一步判定溢价率和胜率,如果近一年内有5次炸板,但溢价率和胜率都能达到88%以上,叠加市场环境的转暖,就可以去仓控考虑打板介入;

反之,如果溢价率和胜率都很低,值博率不高,就没有必要去参与。

 

公式代码:

α:66,COLOREFCC00;
AA:=COUNT(C/REF(C,1)>=1.0994 AND L<C AND C=H,500);
BB:=COUNT(REF(C,1)/REF(C,2)>=1.0994 AND REF(L,1)<REF(C,1) AND REF(C,1)=REF(H,1) AND H>REF(C,1)*1.049,500);
ZZ:=COUNT(REF(H,1)/REF(C,2)>=1.0994 AND REF(C,1)<REF(H,1)*0.98,500);
A:=COUNT(C/REF(C,1)>=1.0994 AND L<C AND C=H,500);
大肉:COUNT(REF(C,1)/REF(C,2)>=1.0994 AND REF(L,1)<REF(C,1) AND REF(C,1)=REF(H,1) AND H>REF(C,1)*1.049,500),COLORFF99FF,NODRAW;
B:=COUNT(REF(C,1)/REF(C,2)>=1.0994 AND REF(L,1)<REF(C,1) AND REF(C,1)=REF(H,1) AND H>REF(C,1)*1.049,500);
溢价率:(B/A)*100,COLORFF99FF;
Z:=COUNT(REF(H,1)/REF(C,2)>=1.0994 AND REF(C,1)<REF(H,1)*0.98,500);
总胜率:A/(A+Z)*100,COLOR9900FF;
AAA:=COUNT(C/REF(C,1)>=1.0094 AND L<C AND C=H AND REF(C,1)/REF(C,2)<1.096,500);
ZZZ:=COUNT(REF(C,2)/REF(C,3)<1.0994 AND REF(H,1)/REF(C,2)>1.0994 AND REF(C,1)<REF(H,1)*0.98,500);
首:AAA/(AAA+ZZZ)*100,COLOR9900FF,NODRAW;
面:COUNT(REF(H,1)/REF(C,2)>=1.0994 AND REF(C,1)<REF(H,1)*0.98,500),COLORYELLOW,NODRAW;{头日砸板 2个点上}
大面:COUNT(REF(H,1)/REF(C,2)>=1.0994 AND REF(C,1)<REF(H,1)*0.95,500),COLORFF6666,NODRAW;{头日砸板 5个点上}
面霸:COUNT(REF(C,2)/REF(C,3)>=1.0994 AND REF(C,2)=REF(H,2) AND (REF(H,1)/L)>=1.17647,500),COLORRED,NODRAW;{两日面超17%}
首炸:COUNT(REF(C,2)/REF(C,3)<1.0994 AND REF(H,1)/REF(C,2)>1.0994 AND REF(C,1)<REF(H,1)*0.98,500),COLORGREEN,NODRAW;{头日砸板2个点以上}
连炸:COUNT(REF(C,2)/REF(C,3)>1.0994 AND REF(C,2)=REF(H,2) AND REF(H,1)/REF(C,2)>1.0994 AND REF(C,1)<REF(H,1)*0.98,500),COLORGREEN,NODRAW;
核A:COUNT(REF(C,1)/REF(C,2)>=1.0994 AND REF(L,1)<REF(C,1) AND REF(C,1)=REF(H,1) AND O<=REF(C,1)*0.95,500),COLORWHITE,NODRAW;
核B:COUNT(REF(H,1)/REF(C,2)>=1.0994 AND REF(C,1)<REF(H,1) AND O<REF(C,1)*0.95,500),COLORWHITE,NODRAW;
三连:COUNT(C/REF(C,3)>=1.3295 AND C>L,500),COLOR9900FF,NODRAW;
涨停:COUNT(C/REF(C,1)>=10994 AND L<C AND C=H,500),COLOR9900FF,NODRAW;
脸:COUNT(REF(H,1)/REF(C,2)>=1.0994 AND REF(C,1)<REF(H,1)*098,250), COLORYELLOW,NODRAW;{一年内头日砸板2个点以上};

三、应用实战

实战一:2019年9月3日国科微三板三封

当日股性栏可以看到,历史连板炸板数为零,并且上板溢价率高达75%,意味着只要是连板上板,过去2年都没有炸过,因此三封充分换手后是有高值博率的买点

【天道兄弟】抓牛进阶实战课:凯利公式的筹码学

【天道兄弟】抓牛进阶实战课:凯利公式的筹码学

实战二: 2019年9月6日中泰股份二板首封

当日股性栏可以看到,历史连板炸板数为2次,虽然溢价率很高,但最近一年有6次炸板(娃娃脸) ,那么一般超过3张脸的首封基本都要小心,排板稍微靠中后位置为主,有撤排最好也要第一时间跟撤。如果溢价率很高,可以等待二封的机会

【天道兄弟】抓牛进阶实战课:凯利公式的筹码学

【天道兄弟】抓牛进阶实战课:凯利公式的筹码学

778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友