通达信强势黄金眼主图指标公式

2021年10月4日
评论
22 3706字
DRAWTEXT_FIX(1,0.3,0.05,0,'当强势黄金眼(增强点/向上)确认后,在破坏和恢复之间循环操作-中线策略'),COLORLIRED;
DRAWTEXT_FIX(1,0.3,0.10,0,'多空区:线上操作,线下不操作;买入恢复点优先,卖出S点优先'),COLORWHITE;
移动:=0;
MA5:MA(C,5),DOTLINE,COLORWHITE;
MA10:MA(C,10),DOTLINE,COLORYELLOW;
MA30:MA(C,30),LINETHICK3,COLOR00FF00;
IF(MA30>=REF(MA30,1),MA30,DRAWNULL),COLORRED,LINETHICK3;
DRAWTEXT(CURRBARSCOUNT=1,MA30,'--MA30'),NODRAW,COLORMAGENTA;
MA150:MA(C,150),LINETHICK2,COLORCYAN;
{BS点}
X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
DRAWICON(CROSS(X2,X3),L*0.98,7)COLORYELLOW;{B点}
XG1:=CROSS(X2,X3),NODRAW;
DRAWICON(CROSS(X3,X2),H*1.01,8);{S点}
STICKLINE(X2>=X3,LOW,HIGH,0,1),COLORRED;{B区K线}
STICKLINE(X2>=X3,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(X2<X3,LOW,HIGH,0,1),COLORCYAN;{S区K线}
STICKLINE(X2<X3,CLOSE,OPEN,3,1),COLORCYAN;
{涨跌停变色K线}
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
ZT:=(C/REF(C,1)-1)*100>9.5;
STICKLINE(ZT,O,C,2.6,0),COLOR0000E5;
STICKLINE(ZT,O,C,2.4,0),COLOR335555;
STICKLINE(ZT,O,C,1.8,0),COLOR338888;
STICKLINE(ZT,O,C,1.2,0),COLOR33AAAA;
STICKLINE(ZT,O,C,0.6,0),COLOR33CCCC;
STICKLINE(ZT,O,C,0.1,0),COLOR33EEEE;
{跌停}
C3:=REF(C,1);
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,C,O,2.5,0),COLOR009900;
STICKLINE(跌停,C,O,1.5,0),COLOR00BB00;
STICKLINE(跌停,C,O,0.8,0),COLOR00DD00;
STICKLINE(跌停,C,O,0.1,0),COLOR00FF00;
{触发点标注}
XA_5:=BARSLAST(CROSS(MA5,MA10));
XA_6:=BARSLAST(CROSS(MA5,MA30));
XA_7:=BARSLAST(CROSS(MA10,MA30));
XA_8:=XA_5>=XA_6 AND XA_6>XA_7 AND XA_5-XA_7<20;
XA_9:=COUNT(CROSS(MA5,MA10),XA_5+1)=1 AND COUNT(CROSS(MA5,MA30),XA_5+1)=1 AND CROSS(MA10,MA30) AND MA5>MA10 AND MA10>MA30;
触发:=XA_8 AND XA_9,NODRAW,COLORWHITE;
DRAWTEXT(触发,H*1.01,'↙触发'),COLORWHITE;
{触发点K线}
STICKLINE(触发,C,O,2.8,0),COLOR555555;
STICKLINE(触发,C,O,2,0),COLOR888888;
STICKLINE(触发,C,O,1.5,0),COLORAAAAAA;
STICKLINE(触发,C,O,1,0),COLORCCCCCC;
STICKLINE(触发,C,O,0.5,0),COLOREEEEEE;
{回踩点标注}
XA_11:=COUNT(触发,BARSLAST(触发)+1)=1 AND COUNT(CROSS(MA30,MA5),BARSLAST(触发)+1)=0;
回踩:=L<=MA30 AND C>MA30 AND XA_11 AND BARSLAST(触发)>0,NODRAW,COLORMAGENTA;
DRAWTEXT(回踩,MA30,'↖回踩'),COLORMAGENTA;
{回踩点K线}
STICKLINE(回踩,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(回踩,C,O,2.5,0),COLORFF00FF;
STICKLINE(回踩,C,O,1.5,0),COLORFF33FF;
STICKLINE(回踩,C,O,0.8,0),COLORFF66FF;
STICKLINE(回踩,C,O,0.1,0),COLORFF99FF;
{破坏点标注}
XA_12:=COUNT(触发,BARSLAST(触发)+1)=1 AND CROSS(MA30,MA5) AND COUNT(CROSS(MA30,MA5),BARSLAST(触发)+1)=1;
破坏:=XA_12>0,NODRAW,COLORLIBLUE;
STICKLINE(破坏,C,O,4,0),COLORBLUE;
STICKLINE(破坏>0,C,O,3,0),COLORBLUE;
STICKLINE(破坏>0,C,O,2.5,0),COLOR730000;
STICKLINE(破坏>0,C,O,1.5,0),COLOR870000;
STICKLINE(破坏>0,C,O,0.8,0),COLOR9B0000;
STICKLINE(破坏>0,C,O,0.1,0),COLORAF0000;
STICKLINE(破坏>0,C,O,0.5,0),COLORC30000;
{多空区标注}
多空区:REF(H,BARSLAST(触发-回踩)),COLOR6427FC,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=1,多空区,'--多空区'),COLOR6427FC;
{增强点标示}
DRAWICON(CROSS(MA30,MA150),L*0.99,1);
DRAWTEXT(CROSS(MA30,MA150),H*1.01,'↙增强点'),COLOR0470EE;
{增强点K线}
STICKLINE(CROSS(MA30,MA150),OPEN,CLOSE,3,0),COLORADDEFF;
STICKLINE(XG1,H,L,0,0),COLOR0022FF;
STICKLINE(CROSS(MA30,MA150),C,O,3.2,0),COLOR002288;
STICKLINE(CROSS(MA30,MA150),C,O,2.6,0),COLOR0033AA;
STICKLINE(CROSS(MA30,MA150),C,O,1.9,0),COLOR0044CC;
STICKLINE(CROSS(MA30,MA150),C,O,1.2,0),COLOR0055EE;
STICKLINE(CROSS(MA30,MA150),C,O,0.6,0),COLOR0077FF;
STICKLINE(CROSS(MA30,MA150),C,O,0.3,0),COLOR0088FF;
{多方炮}
ZDF:=(C/REF(C,1)-1)*100;
LTJ:=(C>O AND REF(C,1)<REF(O,1) AND REF(C,2)>REF(O,2) AND C>REF(C,2));
多方炮:=LTJ,NODRAW,COLORFFAA00;
DRAWTEXT(LTJ,L-0.1,'↖多方炮'),COLORFFAA00;
STICKLINE(CURRBARSCOUNT=30+移动,CONST(LLV(L,180)),CONST(HHV(H,120)),0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=150+移动,CONST(LLV(L,180)),CONST(HHV(H,120)),0,0),COLORCYAN;
位置:=CONST(LLV(L,200)+(HHV(H,200)-LLV(L,200))/80);
DRAWTEXT(CURRBARSCOUNT=30+移动,位置,'距30天')COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=150+移动,位置,'距150天')COLORCYAN;
778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友