通达信神器布林线主图指标公式

2021年8月16日
评论
23 1310字
MID2 := MA(CLOSE,21),COLORWHITE;
UPPER2:=MID2 + 1.96*STD(CLOSE,21),COLORYELLOW;
LOWER2:=MID2 - 1.96*STD(CLOSE,21),COLORYELLOW;
UP2:=MID2 + 2.56*STD(CLOSE,21),COLORFF00FF;
LOOW2:=MID2 - 2.56*STD(CLOSE,21),COLORFF00FF;
{上升趋势}
STICKLINE(C>=MID2,MID2,UP2,2,0),COLOR330066;
{下降趋势}
STICKLINE(C<MID2,MID2,LOOW2,2,0),COLOR545454;
MID:MID2,COLORWHITE;
UPPER:UPPER2,COLORYELLOW;
UP:UP2,COLORFF00FF;
LOWER:LOWER2,COLORYELLOW;
LOOW:LOOW2,COLORFF00FF;
开口:=UP-LOOW;
相离:=C-MID;
DRAWTEXT(C>=MID AND REF(开口,1)=HHV(开口,20),UPPER,'减仓'),COLOR00FF00;
DRAWTEXT(C>=MID AND REF(相离,1)=LLV(相离,5),MID,'加仓');
股价多头:=C>MA(C,5) AND MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20);
DRAWTEXT(FILTER(股价多头,20),LOOW*0.95,'开始建仓'),COLORRED;
DRAWICON(FILTER(股价多头,20),LOWER,1),COLORRED;
DRAWTEXT(CROSS(MID,C),UP,'空仓观望'),COLORYELLOW;
DRAWICON(CROSS(MID,C),UPPER,2),COLORYELLOW;
{K线}
{STICKLINE((CLOSE > OPEN),CLOSE,OPEN,5.2,0),COLOR070084;}
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,4,1),COLOR0000A3;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,3.5,0),COLOR000033;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,3,0),COLOR000066;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,2.0,0),COLOR000099;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,1.5,0),COLOR0000CC;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,1.0,0),COLOR0000FF;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE((CLOSE > OPEN),OPEN,LOW,0.3,0),COLORRED;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0.3,0),COLORRED;
778股票学习网(https://gupiao778.com)提醒您:股市有风险,投资需谨慎!
匿名

发表评论

匿名网友